Back to overview
Degraded
Minecraft network connection issues
Sep 24 at 09:00pm CEST
Resolved
Sep 24 at 10:39pm CEST
The incident has been resolved.
Affected services
Updated
Sep 24 at 10:19pm CEST
We’re back! Our Minecraft network should be up and running. We're monitoring the results.
Affected services
Updated
Sep 24 at 09:44pm CEST
The issue has been identified and we are working on a fix.
Affected services
Created
Sep 24 at 09:00pm CEST
We’re having some trouble with the Minecraft network. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services